Bug #331

Correct lead car may have messed up racing order

Added by Walter Pate over 1 year ago. Updated 5 months ago.

Status:ResolvedStart date:04/27/2017
Priority:NormalDue date:
Assignee:Jamie Pate% Done:

0%

Category:Race scoringSpent time:1.50 h
Target version:1.3.53

Description

This is a report from Emily regarding a recent race
Emily says "We ran into a really weird problem at our club race last week where the running order was incorrect and got worse after I changed the lead car while under green. I'm including the database here. It was 2017 Club Race 1, the race in question was Main event Race 5, Sr. Honda. I was not able to correct the lead car and have it record the order correctly after the first restart in that race. I don't think I did anything wrong...."

See Sr Honda main race 5 lap 6

2017-04-27-WQMA Moscore Backup (1).mbk (529 KB) Walter Pate, 04/27/2017 10:45 PM

correctleadcar.png (46.7 KB) Jamie Pate, 07/26/2018 05:40 PM

History

#1 Updated by Walter Pate over 1 year ago

Emily and I tried to analyze what happened on this race (Lap35 (6)), but could not put our fingers on what went wrong without further testing. Jamie, I would like to sit down with you to go over this race using Tranx replay to see if we can get a better more accurate correct lead car feature
Emily , can you follow up with sending us copies of the hand score sheets?

#2 Updated by Jamie Pate over 1 year ago

Looks like this is being caused by the scoresheet reload from db that happens after a flag is thrown (or after the lead car is corrected) after the lead car has been corrected.

#3 Updated by Jamie Pate over 1 year ago

This feature needs to be rewritten, this new design would not have many of the problems of the current design.
http://dev.moscore.com/projects/moscore-qm/wiki/Scoresheet_20

#4 Updated by Jamie Pate 5 months ago

  • File correctleadcar.png added
  • Status changed from New to Resolved
  • Target version changed from Future to 1.3.53

The new solution for correcting lead cars should help with this problem.
Instead of a popup where the user needs to input the car number, all the cars will be displayed in a new panel, including a 'best guess' for the most likely lead car (based on the gap between each car and the preceding car right when the flag is changed to green.

The underlying mechanism remains the same, so we will have to see if it still glitches out on this specific race via testing!

The program will also attempt to guess whether the green flag was pressed at the right time! If the suggested lead car doesn't match the actual first car that crossed the line, the 'correct lead car' panel will display itself and the user can choose which car is actually leading.

Also available in: Atom PDF