Bug #392

Unable to return to yellow or green after a checkered flag

Added by Jamie Pate 5 months ago. Updated 5 months ago.

Status:ResolvedStart date:07/22/2018
Priority:ImmediateDue date:
Assignee:Jamie Pate% Done:

0%

Category:Race scoringSpent time:1.50 h
Target version:1.3.53

Description

Users want to be able to switch back to yellow or green flag condition after they have pressed the checkered feels button ( e.g. when the flagger has thrown the yellow very late)

History

#1 Updated by Jamie Pate 5 months ago

Managed to get the race scoring code to accept switching back to green or yellow. Still need to fix the race finish calculation

#2 Updated by Jamie Pate 5 months ago

Race finish works, but there's some witness during checkered>yellow>green restarts

#3 Updated by Walter Pate 5 months ago

the issue seems to be delayed mouse/keyboard input signal to Moscore-QM.
if the user is using a wireless mouse/keyboard (surrounded by other wireless device radiation) the mouse input may not be recorded till after the lead car crosses the start finish line

#4 Updated by Walter Pate 5 months ago

Can you put a delay in the Mylaps reported finish of the race (last lap) until the scorer confirms the last lap deserves the checkered flag? or yellow, or red. add control Is Checkered?, Is yellow?, Is red?

#5 Updated by Jamie Pate 5 months ago

No,the issue is when the flagger pulls the yellow at the last minute. The solution is to simply allow the yellow flag after the checkered and convert the checkered passings to green. Switching flags from checkered to green seems impractical because we stop counting laps during the checkered.

#6 Updated by Jamie Pate 5 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF